CRAN Package Check Results for Package BALD

Last updated on 2021-10-20 00:49:32 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.0.0-3 29.02 66.64 95.66 WARN
r-devel-linux-x86_64-debian-gcc 1.0.0-3 22.18 51.98 74.16 WARN
r-devel-linux-x86_64-fedora-clang 1.0.0-3 147.53 WARN
r-devel-linux-x86_64-fedora-gcc 1.0.0-3 120.45 WARN
r-devel-windows-x86_64 1.0.0-3 20.00 8.00 28.00 ERROR
r-devel-windows-x86_64-gcc10-UCRT 1.0.0-3 OK
r-patched-linux-x86_64 1.0.0-3 27.64 65.03 92.67 WARN
r-patched-solaris-x86 1.0.0-3 168.40 OK
r-release-linux-x86_64 1.0.0-3 26.75 64.93 91.68 WARN
r-release-macos-arm64 1.0.0-3 OK
r-release-macos-x86_64 1.0.0-3 OK
r-release-windows-ix86+x86_64 1.0.0-3 17.00 8.00 25.00 ERROR
r-oldrel-macos-x86_64 1.0.0-3 OK
r-oldrel-windows-ix86+x86_64 1.0.0-3 22.00 8.00 30.00 ERROR

Check Details

Version: 1.0.0-3
Check: top-level files
Result: WARN
     Output from running autoreconf:
     configure.ac:43: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:43: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:43: the top level
     configure.ac:116: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:116: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:116: the top level
     configure.ac:134: warning: AC_OUTPUT should be used without arguments.
     configure.ac:134: You should run autoupdate.
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-patched-linux-x86_64, r-release-linux-x86_64

Version: 1.0.0-3
Check: top-level files
Result: WARN
     Output from running autoreconf:
     configure.ac:43: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:43: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:43: the top level
     configure.ac:116: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:116: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:116: the top level
     configure.ac:134: warning: AC_OUTPUT should be used without arguments.
     configure.ac:134: You should run autoupdate.
     configure.ac:43: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:43: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:43: the top level
     configure.ac:116: warning: The macro `AC_HELP_STRING' is obsolete.
     configure.ac:116: You should run autoupdate.
     ./lib/autoconf/general.m4:204: AC_HELP_STRING is expanded from...
     configure.ac:116: the top level
     configure.ac:134: warning: AC_OUTPUT should be used without arguments.
     configure.ac:134: You should run autoupdate.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc

Version: 1.0.0-3
Check: compiled code
Result: NOTE
    File ‘BALD/libs/BALD.so’:
     Found no calls to: ‘R_registerRoutines’, ‘R_useDynamicSymbols’
    
    It is good practice to register native routines and to disable symbol
    search.
    
    See ‘Writing portable packages’ in the ‘Writing R Extensions’ manual.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc

Version: 1.0.0-3
Check: whether package can be installed
Result: ERROR
    Installation failed.
Flavors: r-devel-windows-x86_64, r-release-windows-ix86+x86_64, r-oldrel-windows-ix86+x86_64