CRAN Package Check Results for Package optimall

Last updated on 2021-10-22 00:50:34 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.1.0 7.44 65.23 72.67 OK
r-devel-linux-x86_64-debian-gcc 0.1.0 6.21 48.33 54.54 OK
r-devel-linux-x86_64-fedora-clang 0.1.0 95.92 OK
r-devel-linux-x86_64-fedora-gcc 0.1.0 85.85 OK
r-devel-windows-x86_64 0.1.0 12.00 120.00 132.00 OK
r-devel-windows-x86_64-gcc10-UCRT 0.1.0 ERROR
r-patched-linux-x86_64 0.1.0 6.70 63.69 70.39 OK
r-patched-solaris-x86 0.1.0 104.80 NOTE
r-release-linux-x86_64 0.1.0 8.35 64.74 73.09 OK
r-release-macos-arm64 0.1.0 OK
r-release-macos-x86_64 0.1.0 OK
r-release-windows-ix86+x86_64 0.1.0 13.00 111.00 124.00 OK
r-oldrel-macos-x86_64 0.1.0 OK
r-oldrel-windows-ix86+x86_64 0.1.0 13.00 105.00 118.00 OK

Check Details

Version: 0.1.0
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: 'DiagrammeR'
Flavor: r-devel-windows-x86_64-gcc10-UCRT

Version: 0.1.0
Check: examples
Result: ERROR
    Running examples in 'optimall-Ex.R' failed
    The error most likely occurred in:
    
    > ### Name: multiwave_diagram
    > ### Title: Print Summary Diagram of Multiwave Object
    > ### Aliases: multiwave_diagram
    >
    > ### ** Examples
    >
    > MySurvey <- new_multiwave(phases = 2, waves = c(1, 3))
    > multiwave_diagram(MySurvey)
    Error: Please install DiagrammeR: install.packages('DiagrammeR').
     Otherwise, try 'summary()'
    Execution halted
Flavor: r-devel-windows-x86_64-gcc10-UCRT

Version: 0.1.0
Check: tests
Result: ERROR
     Running 'testthat.R'
    Running the tests in 'tests/testthat.R' failed.
    Complete output:
     > library(testthat)
     > library(optimall)
     >
     > test_check("optimall")
     ══ Failed tests ════════════════════════════════════════════════════════════════
     ── Error (test-multiwave_diagram.R:38:3): multiwave_diagram works ──────────────
     Error: Please install DiagrammeR: install.packages('DiagrammeR').
     Otherwise, try 'summary()'
     Backtrace:
     █
     1. └─optimall::multiwave_diagram(MySurvey) test-multiwave_diagram.R:38:2
    
     [ FAIL 1 | WARN 0 | SKIP 0 | PASS 202 ]
     Error: Test failures
     Execution halted
Flavor: r-devel-windows-x86_64-gcc10-UCRT

Version: 0.1.0
Check: re-building of vignette outputs
Result: WARN
    Error(s) in re-building vignettes:
    --- re-building 'Multiwave-Object.Rmd' using rmarkdown
    Quitting from lines 11-49 (Multiwave-Object.Rmd)
    Error: processing vignette 'Multiwave-Object.Rmd' failed with diagnostics:
    there is no package called 'DiagrammeR'
    --- failed re-building 'Multiwave-Object.Rmd'
    
    --- re-building 'optimall-vignette.Rmd' using rmarkdown
    Quitting from lines 13-25 (optimall-vignette.Rmd)
    Error: processing vignette 'optimall-vignette.Rmd' failed with diagnostics:
    there is no package called 'DiagrammeR'
    --- failed re-building 'optimall-vignette.Rmd'
    
    --- re-building 'using-optimall_shiny.Rmd' using rmarkdown
    --- finished re-building 'using-optimall_shiny.Rmd'
    
    SUMMARY: processing the following files failed:
     'Multiwave-Object.Rmd' 'optimall-vignette.Rmd'
    
    Error: Vignette re-building failed.
    Execution halted
Flavor: r-devel-windows-x86_64-gcc10-UCRT

Version: 0.1.0
Check: installed package size
Result: NOTE
     installed size is 5.2Mb
     sub-directories of 1Mb or more:
     doc 2.1Mb
     shiny-app 1.0Mb
Flavor: r-patched-solaris-x86